Google Chrome To Block Outdated Plug-Ins

Future versions of the Google Chrome web browser will block out-of-date plugins and will help users automatically update them. No word yet on when Google Chrome will add this feature. “Some plug-ins are widely installed but typically not required for today’s Internet experience,” stated Google in a blog post. “For most users, any attempt to instantiate such a plug-in is suspicious and Google Chrome will warn on this condition.” [CNET]

This article was written by Amit Chowdhry. You can follow me at @amitchowdhry or on Google+ at
Leave a Comment