Now You Need Windows Phone 7.5 To Access Marketplace

Posted May 23, 2012

This afternoon Microsoft is going to make it required for you to be running on Windows Phone 7.5 to download, buy, update, or review apps on Marketplace. This change applies to the phone and web Marketplace storefronts. Most phones already run on Windows Phone 7.5, which launched last fall so most of you will not notice anything different. However if you phone has an older version of the Windows Phone operating system, you will soon start seeing an error message. If you want to update your Windows Phone version, visit Update Central.